Challenger - Calls Continuing to Ring – Incident details

All systems operational

Calls Continuing to Ring

Resolved
Degraded performance
Started about 1 month agoLasted 32 minutes

Affected

Phone Systems

Degraded performance from 11:28 AM to 11:35 AM, Operational from 11:35 AM to 12:00 PM

CallSwitch Phone System

Degraded performance from 11:28 AM to 11:35 AM, Operational from 11:35 AM to 12:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Expected performance has resumed across the affected zone and we are seeing service return to normal for those affected accounts. We will continue monitoring for an extended period.

  • Identified
    Identified

    Our team have identified the affected services and are working to resolve. Will provide a further update within 20 minutes.

  • Investigating
    Investigating

    We're investigating some reports of calls continuing to ring after being picked up by an extension and audio disruption, on some end user accounts. We are seeing traffic flowing normally on most. Our team are investigating with priority. Will provide a further update in 20 minutes.