Challenger - Call Switch Dashboard – Incident details

All systems operational

Call Switch Dashboard

Resolved
Degraded performance
Started 8 days agoLasted about 22 hours

Affected

Phone Systems

Degraded performance from 11:36 AM to 11:44 AM, Under maintenance from 11:44 AM to 12:07 PM, Operational from 12:07 PM to 12:07 PM, Under maintenance from 12:07 PM to 9:07 AM

CallSwitch Phone System

Degraded performance from 11:36 AM to 11:44 AM, Under maintenance from 11:44 AM to 12:07 PM, Operational from 12:07 PM to 12:07 PM, Under maintenance from 12:07 PM to 9:07 AM

Updates
  • Resolved
    Resolved

    After a period of successful monitoring the supplier is marking this incident as resolved.

  • Update
    Update

    The fix has been implemented on this zone and services should have returned to normal for the impacted accounts. We will continue monitoring all services for a prolonged period and provide further information ASAP.

  • Update
    Update

    We're seeing the same reported issues on the zone that was unaffected earlier today. We are rolling out the same fix and service should be restored very shortly. Will provide further update in 15 mins.

  • Update
    Update

    A fix has been implemented across the two degraded zones, and we've seen traffic return to normal on both. We will continue to monitor for an extended period and update further with any new information.

  • Update
    Update

    We are still working on more permanent fixes to allow us to restore service for all users. Will update again within 30 mins.

  • Update
    Update

    We're still working on addressing issues reported on some accounts. Will update again in next 30 minutes.

  • Update
    Update

    We are still seeing intermittent reports of issues on calls, and slow load times on dashboards and desktop apps. We're working on addressing both so for those still seeing issues we will provide a further update in the next 15 minutes.

  • Update
    Update

    Dashboards should now be restored, as well as presence indicators on apps and handsets. We are seeing previously delayed messages reaching endpoints, so reports of no audio may be symptomatic of calls attempted previously. New calls should be returning to normal. We will continue to monitor and update the status once satisfied all services have resumed.

  • Monitoring
    Monitoring

    A fix has been implemented and we are beginning to see traffic return to normal and services resuming across the board. We will update again within 15 minutes.

  • Identified
    Identified

    We've identified the issue and are implementing a fix. Will provide update in next 15 minutes.

  • Investigating
    Investigating

    We are currently investigating reports of issues with Dashboard and presence, as well as calling affected on some accounts. We are looking with urgency.